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General overview

Purpose of LYX

TL;DR: LYX makes it easy to create good-looking technical papers.

LYX is designed using the WYSIWYM (what you see is what you mean) paradigm, versus
standard word processors like MS Word, which use WYSIWYG (what you see is what
you get). This means that when you want to add a section heading, you select ’Section’ in
the drop-down menu to the top left, and LYX will take care of the formatting. It also has a
very powerful and flexible math typesetting system. LYX takes a bit of adjustment, but it
means that you don’t have to remember which font size you’ve been using for headings,
or futz around with spacing. It isn’t always the right tool for a particular job; it’s good at
making great-looking technical papers and reports, but it’s much harder to fiddle around
with graphic placement and fonts like you might want to for a poster.

If you’ve ever used LATEX, you should be right at home–LYX is built as a graphical interface
on top of LATEX, abstracting away the class declarations and control symbols that clutter
up LATEX source files and instead showing you something that’s closer to the final result.
You can still enter raw LATEX (called ERT for Evil Red Text in LYX) as needed with the
Ctrl+l1 shortcut, and LYX continuously maintains a LATEX source file (click View→Source
Pane) so you can see what’s going on under the hood. LYX has been around for 15 years
and most functions are available within the GUI, so you shouldn’t need to use ERT too
often.

You can either download LYX from lyx.org and install it on a personal machine, or use the
version installed on the CAE Windows and Linux lab computers. The CAE version has
several quirks, so I recommend installing and using LYX on a personal laptop or desktop.

Hello, world

To jump right into LYX, start by clicking the New document icon in the top left of the screen.
You can also use the shortcut2 Ctrl+n, or select File→New. Enter a title by selecting Title
in the drop-down box to the top left, and then typing your desired title text. Hit enter/re-
turn, select Author from the drop-down, and type in your own name. Hit enter again and
select Section if you’d like a section heading for your document (or subsection, or what-
ever’s needed). Hit enter once again (the drop-down box3 should now say Standard) and
start typing your body text. You’ll notice right away that LYX doesn’t allow you to enter
multiple spaces or returns, since it takes care of inter-sentence and inter-line spacing. If

1When I refer to shortcuts, capitalization is meaningful. Lowercase letters should be typed as written,
and uppercase letters should be typed as shift+[letter].

2You’ll find that most common keyboard shortcuts behave as expected, e.g. Ctrl+s to save, Ctrl+f to find,
Ctrl+z to undo, and Ctrl+x/c/v to cut/copy/paste. Hovering over menu items will display a tooltip which
includes the item’s shortcut if available.

3You can access this drop-down menu quickly with Alt+p <spacebar>; type to filter the entries.
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you really need multiple spaces or returns, use Ctrl+Space/Return. After you’ve typed
a bit, hit View (googly eyes button to the top left) to generate a pdf file you can save or
print. If you make changes to the LYX file, click the Update icon (next to View) to update
the pdf. Note that saving the output doesn’t save the LYX file—you’ll need to save both.

Using LYX on CAE lab computers

Happily, CAE recently decided to install LYX on the Windows lab computers. It can be
found in the start menu under Programs→Productivity→ LyX. However, the LYX installa-
tion is a bit mangled, making it more likely to produce errors. Two known errors:

• If you try to compile a document without changing any settings on the CAE com-
puters, you may get an obscure-looking error that says something about ’Babel lan-
guage package’. To fix this, go to Documents→Settings→Language and change the
language package from ’Default’ to ’None’.
• For some reason, the CAE LYX install doesn’t like long filenames on graphics in-

cluded in LYX. To avoid running into errors, try to keep filenames quite short (e.g.
gaussquad.png)

Document settings

If you need to change the appearance or behavior of the document you’re writing, click
Document→Settings to open the Document Settings menu (surprise!). There are many op-
tions available here, but you won’t need to worry about most of them. First and foremost
is the document class–for short papers, use Article (Standard Class), while Report (Standard
Class) is appropriate for longer documents. Click the document class drop-down and start
typing the class name to filter the drop-down list, then select the class. Greyed-out docu-
ment classes aren’t available on your LYX installation–if you want to use them, you’ll need
to download and install class definition files, then refresh LYX with Tools→Reconfigure.
Googling will provide a more detailed guide to the process, but you really shouldn’t
need to install other class files. You can also play with Fonts, Text Layout, Page Layout, Page
Margins, Numbering & TOC, and Float Placement. Other menu items might require reading
the (very useful, but lengthy) LYX user’s guide, Googling, or asking me.

Adding graphics and tables

To add a graphic (picture, graph, etc.) to the document, go to Insert→Graphics, click the In-
sert Graphics (borderless triangle-circle-square) icon, or use Alt+i+g. LYX outputs graph-
ics pixel-for-pixel, so if you have a very large graphic, it will probably be far too large in
the pdf output. To shrink graphics down to a more reasonable size, click on the graphic,
click the ’Set width’ checkbox in the popup that appears, and enter an appropriate width.
The body text is 16.5 cm wide by default; I resize most graphics to be 6-12 cm wide.
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To add a table, go to Insert→Table, click the Insert Table (grid) icon, or use Alt+i+t. To
paste text from Excel or another spreadsheet, create a table of same dimensions as the
copied spreadsheet cells, put the cursor in the upper-left cell, and use Ctrl+Shift+v.

Most ’professional’ technical reports and articles use figure/table floats, which set the fig-
ure/table apart from body text and append a figure/table number and description. Add
floats through Insert→Float→. . . or the float icons, which are the Insert Graphics/Insert
Table icons but with a dotted border around the outside.

(a) Overhead view of assembly (b) Assumed passenger dimensions

Figure 1: Assumptions and definitions

To refer to the figure from elsewhere in the text, place the cursor in the float description
box, insert a label (Insert→Label or Alt+i+l), and enter a descriptive label. Then, create the
reference with Insert→Cross-Reference or Alt+i+r

LYX sometimes has strange opinions about where figures should go within the text. To
change the default location of figures (relative to the insertion point) for the entire docu-
ment, go to Document→Settings→Float Placement. To change the location of an individual
figure, right-click on the ’float: Figure’ box heading and select ’Settings’ from the drop-
down menu.

Further reading

The LyX Essentials goes into greater depth than this summary, although it doesn’t de-
scribe available shortcuts. Check it out if you’re concerned with bulleted or numbered
lists, cross-referencing and citations, or bibliographies.

The LaTeX Mathematics Companion covers basically every aspect of LATEX math typeset-
ting. If you have a math formatting question that Google can’t answer, you can probably
find the solution here.
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The built-in manuals are also worth a look; they can either be viewed in LYX or compiled
into a PDF. Find them in the ’Help’ section of the top menu bar.

Math maneuvers

One of LYX’s great strengths is the ease (and eventually, speed) with which math can be
typed. The following text is half tutorial, half style guide.

To enter LYX’s inline (as in y = mx + b) math mode, click the ∑ button at the top of
the screen, or use Ctrl+m. To enter display math mode (for large or important math
expressions), use Ctrl+M:

ẍ +
kx
M

= 0

For multi-line equations, use Ctrl+M to enter display math mode, then Alt+m+a to create
an aligned multi-line equation. You’ll see a template with two boxes appear; the equations
will be aligned along the division between the two boxes. It’s good practice to always
keep your equality signs on one side next to the inter-box division so your equalities are
aligned in the output:

HP = ∑
i

ρi ×mi ṙi

hP = ∑
i

ρi ×miρ̇i

Once you’ve entered math mode, you’ll see a math palette appear at the bottom of LYX
with hundreds of common symbols and expressions. You can click items to add them to
the text at your cursor’s location. Hovering over items in the palette shows the shortcut
key combo that produces the symbol. Learning these shortcuts will take some time, but
doing so will allow you to enter math expressions into documents very rapidly.

To add number labels to a single displayed equation or all lines of a multi-line equation,
use Alt+m+n. To add or remove numbering from a single line in a multi-line equation,
use Alt+m+N.

σrr =

Internal pressure︷ ︸︸ ︷
pib2

a2 − b2

(
1− a2

r2

)
−

External pressure︷ ︸︸ ︷
poa2

a2 − b2

(
1− b2

r2

)
(1)

σθθ =
pib2

a2 − b2

(
1 +

b2

r2

)
− poa2

a2 − b2

(
1 +

b2

r2

)
(2)

If you want to refer to an equation from elsewhere in the document, insert a descriptive
label (Alt+i+l) with your cursor inside the equation. For example, my label for equation 1
is eq:sigma_rr. The nice thing about referencing equations through labels is that if you add
numbered equations to a document later on, LYX automatically updates the numbering
of in-text references. As motivation, imagine manual updating, where you’d need to
hunt through text for equation references and change them by hand after adding a new
equation above.
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Shortcuts and special characters

Standard LATEX uses the backslash \ as a control character. Typing it in math mode will
almost always make something happen. All Greek characters can be accessed by typing
a backslash, then the character needed, e.g. \alpha for α. Non-keyboard (integration,
summation, product, etc.) math operators are accessed similarly, as in \frac for a

b , or \sin
for sin(a). It’s important to use the backslash version of math operators to distinguish
them from the symbols they operate on–see sinx vs. sin x, or limx → 3 vs lim

x→3
.

To quickly access Greek letters, type Alt + m + g + [roman character]
For example, Alt + m + g + a→ α; Alt + m + g + d→ δ.

Some Greek characters have unexpected shortcuts:

Character ε ε η θ φ ϕ ψ ∆
Alt+m+g+ e E h v f j y D

Many other math characters can be accessed with Alt + m + . . . , although some cannot.
Using α and β as dummy characters:

Function Integration Sum Multiply Product Vector Hat Infinity
LATEX \int \sum \cdot \times \vec \hat \infty

Output
´

∑ · × →
α α̂ ∞

Alt+m+ i u — — v h 8

Function Partial Fraction Square root Root Time deriv. 2nd time deriv
LATEX \partial \frac \sqrt \root \dot \ddot

Output ∂
α

β

√
α β

√
α α̇ α̈

Alt+m+ p f s r . (period) “ (quot. mark)

To get delimiters ( (), {}, [], etc.) which automatically resize to fit whatever they contain,
type Alt + m + {the opening delimiter}, e.g. ’Alt + m + (’ for auto-resizing parentheses.
This ends up looking like

sin
(

1
x

)
or
(

1 0
0 1

)
It’s best to not use auto-resizing delimiters if you know the expression will be standard
(short) height, since auto-resizing adds extra space before and after the delimiters.

Making fractions fit

When typing inline equations with fractions, the standard \frac (Alt+m+f) will probably
compress the characters in the fraction beyond the bounds of readability. It’s better to use
the forward slash (1/2) or use \nicefrac, which produces 1/2. There are some exceptions–
for example, π

2 is perfectly legible inline. However, more-complicated fractions such as
αx+β
δy+δ will force LATEX to increase the inter-line spacing around the line, resulting in an ugly
document. Better to use \nicefrac: αx+β/γy+δ, or nothing at all: (αx + β)/(γy + β)
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To limit the size of a fraction in a displayed equation (non-inline), use \tfrac instead of
\frac, which produces

3 a
b + 5 c

d and 1
4 sin x

instead of
3

a
b
+ 5

c
d

and
1
4

sin x

It is only occasionally better to use \tfrac in a displayed equation, though–most of the
time, especially in fractions with multiple characters, \frac works nicely:

sin
nπx

4

Math operators

LYX has built-in templates for many math operators including fractions, exponents, sub-
scripts, and sums. Shift+_ produces a subscript, and Shift+^ produces a superscript; add
these to integrals to define bounds, or to sums to define conditions.

There are several different conventions for differentiation; pick whichever your profes-
sor/P.I./textbook seems to be attached to. Differentiation can be written as dy or dy (up-
right4 or italic d), or with apostrophes as in f ′(x). When integrating, it is good practice to
separate the differentials from the integrated expression with small spaces inserted using
Ctrl + Space: ˆ 3

0

ˆ 1

−1
x2y dx dy

Table 1: Common multiple integrals
¨ ˚ ˛ ‹

\iint \iiint \oint \oiint

When looking at multiple integrals with a single subscript used to describe the integrated
area, it is good practice to typeset the subscript entirely below, typing \iint\limits_A 3x \dd{A}
to produce

¨

A

3x dA

For closed surface integrals (and some multiple integrals), convention seems to be stan-
dard subscript notation, e.g. ˛

L
or
¨

B

4If using the Physics package to extend LATEX math, the upright ’d’ can be accessed with \dd. To au-
tomatically add proper spacing in front of the ’d’ operator, enclose the operand with curly braces (e.g.
\int x\dd{x} for

´
x dx
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When typing multiple stacked fractions, use \cfrac, which produces

a0 +
b1

a1 +
b2

a2 +
b3

a3 + . . .

If writing a sum with multiple indices, add a subscript to the sum, type \substack, and
use Ctrl+Enter to add additional rows of indices as in the following example:

∑
0≤i≤m
0<j<n

P(i, j)

Vectors

There are two main conventions for vectors: either an arrow above the vectorized charac-
ter (

→
ρ ) or bolding the character (ρ). The former is standard behavior, accessed through

Alt+m+v. If you want the latter instead, add the command
renewcommand{\vec}[1]{\bm{#1}
to your LATEX preamble in the Document Settings menu (described further on the follow-
ing page in Advanced Fiddling)

Matrices

To insert a matrix, enter math mode with Ctrl+M, click the purple ‘Insert Matrix’ icon,
and choose the numbers of rows and columns needed. To add vertical delimiters within
the matrix, type ccc (for three columns) in the Alignment→Horizontal: text box, with a
pipe character where the delimiter is wanted. For the matrix below, I inserted a 3-row,
4-column matrix, then typed ‘ccc|c’ in the text box. 5/6 2 3 4

5 6 7 8
1 2 3 4


To add pretty delimiters to a matrix (hugged around the numbers composing the matrix),
select a Decoration in the math matrix creation window. Unfortunately, it doesn’t seem
possible to use in-matrix delimiters and pretty delimiters simultaneously.

For special matrices which aren’t natively supported by LYX, enter ERT (Evil Red Text)
mode with Ctrl+l and start a math environment from scratch. For example, to obtain a
matrix with bordering characters, use the following ERT:
\[\bordermatrix{~ & x & y \cr

A & 1 & 0 \cr
B & 0 & 1 \cr}\]
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which produces

( x y
A 1 0
B 0 1

)

Defining your own operators

Notice that when you type a common math operator with a backslash before it while
in math mode (\sin or \exp), LYX typesets them without italics, which helps to set the
operator apart from its target. If your work requires you to create an operator, you can
predefine its behavior in LYX using math macros (the \foo

:= button in the top toolbar) , then
type carefree. Several examples are included in this doc. If you’re reading a pdf version,
open LYX and go to Help→Math, then search for ’math macros’.

When creating a macro, use the green Append argument button to... well, append argu-
ments. Then, enter the expression you’d like to generate automatically, with an argument
placeholder (typed as \#1, \#2, etc.) wherever needed. It’s also possible to define a math
macro without any arguments, which will just produce a pre-defined character.

If you use the same macros frequently, it’s probably a good idea to create a LYX file that
only contains the macro definitions, then include it at the very top of your active docu-
ment with Insert→File→Child Document. You’ll then be able to use the macros without
redefining them for each new doc.

Advanced Fiddling

As you might expect, nearly any LYX-related question can be answered by Google or
StackOverflow. Search for ’lyx [keywords]’ for UI-related questions, or ’latex [keywords]’
for formatting-related questions. For example, when I wanted to figure out how to change
the font of section and subsection headings, I searched for ’latex change section font’ and
implemented the first search result.

Much advanced fiddling will require changes to the document’s LATEX preamble, a plain-
text file found at the bottom of Document Settings. My standard preamble is included at
the end of the document.

What I’ve discovered (and want to record)

Left-aligned equations with flalign:

Change the equation environment with the right-click menu, then add a column with the
table toolbar. Add a blank set { } to the rightmost column, otherwise LYX will ignore the
added column. See here.
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Centering graphics inline:

When there’s a piece of inline graphics that should be centered vertically with respect to
the text, wrap the graphics with $\vcenter{\hbox{ and }}$.

Listing 1: Standard LyX preamble
\usepackage{multicol} % Make documents with multiple columns.
% To enter the multicol environment, use ERT (Ctrl+l) and type \begin{multicols}{2} % for two

columns, or ...{3} for three columns, etc. Once finished. re-enter ERT
% and type \end{multicols}. To add divider lines between cols, add another ERT box
% with \setlength{\columnseprule}{0.4pt} immediately after \begin{multicols}{...}

\usepackage{bm} % Allows use of bold Greek characters
\usepackage{physics}
\renewcommand{\vec}[1]{\bm{#1}} % Redefines vector command to bold the vectorized character.

% Shrinks the spacing between bulleted and numbered lists
\let\oldenumerate=\enumerate
\def\enumerate{
\oldenumerate
\setlength{\itemsep}{-3pt}
}
\let\olditemize=\itemize
\def\itemize{
\olditemize
\setlength{\itemsep}{-3pt}
}

% Changes the section and subsection heading font families from roman to sans serif
\usepackage{titlesec}
\titleformat*{\section}{\Large\bfseries\sffamily}
\titleformat*{\subsection}{\large\bfseries\sffamily}

% Automatically centers figures inside figure floats
\usepackage{ifthen}
\renewenvironment{figure}[1][]{%
\ifthenelse{\equal{#1}{}}{%

\@float{figure}
}{%

\@float{figure}[#1]%
}%
\centering
}{%
\end@float
}

% Automatically centers tables inside of table floats
\renewenvironment{table}[1][]{%
\ifthenelse{\equal{#1}{}}{%
\@float{table}

}{%
\@float{table}[#1]%

}%
\centering
}{%
\end@float
}
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